aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorJunio C Hamano <junkio@cox.net>2005-08-13 00:12:51 -0700
committerJunio C Hamano <junkio@cox.net>2005-08-13 00:12:51 -0700
commit755d62788f0507781dbbf0ed1278b65ff4829185 (patch)
treebe21e68b1c62bf14fc6a2d0f0f94dcb856f1ddad /debian
parent8eb14dc1882ade6f881ae93dfd7ecaa0dc0f0fdc (diff)
parentaf36b70ef939cc44c447a4b9cbaadd7eba9a20b1 (diff)
downloadgit-755d62788f0507781dbbf0ed1278b65ff4829185.tar.gz
Merge master changes into release candidate branch.
Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules58
3 files changed, 39 insertions, 29 deletions
diff --git a/debian/changelog b/debian/changelog
index 28cfb0f84f..da7526e2cb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,12 @@ git-core (0.99.5-0) unstable; urgency=low
-- Junio C Hamano <junkio@cox.net> Wed, 10 Aug 2005 22:05:00 -0700
+git-core (0.99.4-4) unstable; urgency=low
+
+ * Mark git-tk as architecture neutral.
+
+ -- Junio C Hamano <junkio@cox.net> Fri, 12 Aug 2005 13:25:00 -0700
+
git-core (0.99.4-3) unstable; urgency=low
* Split off gitk.
diff --git a/debian/control b/debian/control
index 53b87f44a6..5df89dde32 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Standards-Version: 3.6.1
Package: git-core
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, patch, rcs
+Depends: ${shlibs:Depends}, ${perl:Depends}, ${misc:Depends}, patch, rcs
Recommends: rsync, curl, ssh, libmail-sendmail-perl, libemail-valid-perl
Conflicts: git
Description: The git content addressable filesystem
@@ -18,7 +18,7 @@ Description: The git content addressable filesystem
similar to other SCM tools.
Package: git-tk
-Architecture: any
+Architecture: all
Depends: ${shlibs:Depends}, ${misc:Depends}, git-core, tk8.4
Description: The git content addressable filesystem, GUI add-on
This package contains 'gitk', the git revision tree visualizer.
diff --git a/debian/rules b/debian/rules
index 921aeecfb4..c46b4d9466 100755
--- a/debian/rules
+++ b/debian/rules
@@ -56,7 +56,8 @@ install: build
dh_clean -k
dh_installdirs
- make dest=$(DESTDIR) prefix=$(PREFIX) mandir=$(MANDIR) install install-tools install-doc
+ make DESTDIR=$(DESTDIR) prefix=$(PREFIX) mandir=$(MANDIR) \
+ install install-doc
mkdir -p $(DOC_DESTDIR)
find $(DOC) '(' -name '*.txt' -o -name '*.html' ')' -exec install {} $(DOC_DESTDIR) ';'
@@ -65,33 +66,36 @@ install: build
dh_movefiles -p git-core
find debian/tmp -type d -o -print | sed -e 's/^/? /'
-binary: build install
+binary-arch: build install
dh_testdir
dh_testroot
- dh_installchangelogs
- dh_installdocs
- dh_installexamples
-# dh_installmenu
-# dh_installdebconf
-# dh_installlogrotate
-# dh_installemacsen
-# dh_installpam
-# dh_installmime
-# dh_installinit
-# dh_installcron
-# dh_installinfo
- dh_installman
- dh_link
- dh_strip
- dh_compress
- dh_fixperms
-# dh_perl
-# dh_python
- dh_makeshlibs
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
+ dh_installchangelogs -a
+ dh_installdocs -a
+ dh_strip -a
+ dh_compress -a
+ dh_fixperms -a
+ dh_perl -a
+ dh_makeshlibs -a
+ dh_installdeb -a
+ dh_shlibdeps -a
+ dh_gencontrol -a
+ dh_md5sums -a
+ dh_builddeb -a
+
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs -i
+ dh_installdocs -i
+ dh_compress -i
+ dh_fixperms -i
+ dh_makeshlibs -i
+ dh_installdeb -i
+ dh_shlibdeps -i
+ dh_gencontrol -i
+ dh_md5sums -i
+ dh_builddeb -i
+
+binary: binary-arch binary-indep
.PHONY: build clean binary install clean debian-clean