aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorMatthias Urlichs <smurf@smurf.noris.de>2005-08-11 01:54:36 +0200
committerJunio C Hamano <junkio@cox.net>2005-08-11 18:26:14 -0700
commit5acc5bfd6303f1fec4b3d175a15a2ff800983be7 (patch)
tree3cdb6322ac891c443fa72c238b071e533017ab2f /debian
parentb4ad66b7785c27ba05df78841b6f599e7207ee3d (diff)
downloadgit-5acc5bfd6303f1fec4b3d175a15a2ff800983be7.tar.gz
Debian packaging fixes.
- Split gitk off to its own package; it needs tk installed, but nothing else does. - Refer to GPL properly, don't install COPYING. - Fix maintainer. - Use dh_movefiles instead of dh_install; we don't want to list everything *except* gitk. Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control10
-rw-r--r--debian/copyright25
-rw-r--r--debian/docs2
-rw-r--r--debian/git-core.files1
-rw-r--r--debian/git-core.install1
-rw-r--r--debian/git-tk.files1
-rwxr-xr-xdebian/rules4
8 files changed, 44 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index dbc61209d8..85d4d0094f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+git-core (0.99.4-3) unstable; urgency=low
+
+ * Split off gitk.
+ * Do not depend on diff which is an essential package.
+ * Use dh_movefiles, not dh_install, to stage two subpackages.
+
+ -- Matthias Urlichs <smurf@debian.org> Thu, 11 Aug 2005 01:43:24 +0200
+
git-core (0.99.4-2) unstable; urgency=low
* Git 0.99.4 official release.
diff --git a/debian/control b/debian/control
index 8bdbd731f3..53b87f44a6 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Standards-Version: 3.6.1
Package: git-core
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, patch, diff, rcs
+Depends: ${shlibs:Depends}, ${misc:Depends}, patch, rcs
Recommends: rsync, curl, ssh, libmail-sendmail-perl, libemail-valid-perl
Conflicts: git
Description: The git content addressable filesystem
@@ -15,5 +15,11 @@ Description: The git content addressable filesystem
and flexible filesystem-based database designed to store directory trees
with regard to their history. The top layer is a SCM-like tool which
enables human beings to work with the database in a manner to a degree
- similar to other SCM tools (like CVS, BitKeeper or Monotone).
+ similar to other SCM tools.
+
+Package: git-tk
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, git-core, tk8.4
+Description: The git content addressable filesystem, GUI add-on
+ This package contains 'gitk', the git revision tree visualizer.
diff --git a/debian/copyright b/debian/copyright
index 32b7e9c540..ea61effc40 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -1,3 +1,24 @@
-License:
+This package was downloaded from ftp.kernel.org:/pub/software/scm/git/.
-GPL v2 (see COPYING for details)
+Upstream Author: Linus Torvalds and many others
+
+Copyright:
+
+ Copyright 2005, Linus Torvalds and others.
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; version 2 dated June, 1991.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
+ 02111-1307, USA.
+
+On Debian GNU/Linux systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/docs b/debian/docs
index a252d0f2ca..e845566c06 100644
--- a/debian/docs
+++ b/debian/docs
@@ -1,3 +1 @@
README
-COPYING
-
diff --git a/debian/git-core.files b/debian/git-core.files
new file mode 100644
index 0000000000..74e4e23b01
--- /dev/null
+++ b/debian/git-core.files
@@ -0,0 +1 @@
+/usr
diff --git a/debian/git-core.install b/debian/git-core.install
deleted file mode 100644
index 72e8ffc0db..0000000000
--- a/debian/git-core.install
+++ /dev/null
@@ -1 +0,0 @@
-*
diff --git a/debian/git-tk.files b/debian/git-tk.files
new file mode 100644
index 0000000000..3801e7564b
--- /dev/null
+++ b/debian/git-tk.files
@@ -0,0 +1 @@
+/usr/bin/gitk
diff --git a/debian/rules b/debian/rules
index 2c575ffa19..921aeecfb4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -61,7 +61,9 @@ install: build
mkdir -p $(DOC_DESTDIR)
find $(DOC) '(' -name '*.txt' -o -name '*.html' ')' -exec install {} $(DOC_DESTDIR) ';'
- dh_install --list-missing --sourcedir=$(DESTDIR)
+ dh_movefiles -p git-tk
+ dh_movefiles -p git-core
+ find debian/tmp -type d -o -print | sed -e 's/^/? /'
binary: build install
dh_testdir