aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Narebski <jnareb@gmail.com>2006-09-05 00:57:45 +0200
committerJunio C Hamano <junkio@cox.net>2006-09-04 18:55:35 -0700
commitf8affe317dbfa3d5eb3cc2705568efc184f844db (patch)
tree3dba96d0b30aad68030dcf51496c1c9c9d1ae5a2 /configure.ac
parentc23cca17202f6b04cb2f8f850dac6afc289bcd3d (diff)
downloadgit-f8affe317dbfa3d5eb3cc2705568efc184f844db.tar.gz
autoconf: Check for subprocess.py
Add custom test for checking if Python comes with subprocess.py, or should we use our own subprocess.py by defining WITH_OWN_SUBPROCESS_PY. Signed-off-by: Jakub Narebski <jnareb@gmail.com> Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fc5b813ec7..6fc554e3a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -261,6 +261,16 @@ AC_SUBST(NO_SETENV)
# Enable it on Windows. By default, symrefs are still used.
#
# Define WITH_OWN_SUBPROCESS_PY if you want to use with python 2.3.
+AC_CACHE_CHECK(for subprocess.py,
+ ac_cv_python_has_subprocess_py,
+[if $PYTHON_PATH -c 'import subprocess' 2>/dev/null; then
+ ac_cv_python_has_subprocess_py=yes
+else
+ ac_cv_python_has_subprocess_py=no
+fi])
+if test $ac_cv_python_has_subprocess_py != yes; then
+ GIT_CONF_APPEND_LINE([WITH_OWN_SUBPROCESS_PY=YesPlease])
+fi
#
# Define NO_ACCURATE_DIFF if your diff program at least sometimes misses
# a missing newline at the end of the file.