aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBrandon Casey <casey@nrlssc.navy.mil>2009-07-10 12:10:45 -0500
committerJunio C Hamano <gitster@pobox.com>2009-07-10 23:50:29 -0700
commitecc395c112b45b00df6c8b1e8d665123c1a28bca (patch)
treeace6b76d15e018742384379d0af83260d030538c /configure.ac
parent9398b85994ee7d602e29e0b82de01b9605ee535f (diff)
downloadgit-ecc395c112b45b00df6c8b1e8d665123c1a28bca.tar.gz
Makefile: add NEEDS_LIBGEN to optionally add -lgen to compile arguments
Commit 003b33a8 recently added a call to basename(). On IRIX 6.5, this function resides in libgen and -lgen is required for the linker. Update configure.ac too. Signed-off-by: Brandon Casey <casey@nrlssc.navy.mil> Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1885674e39..74d0af52a5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -485,6 +485,12 @@ AC_CHECK_LIB([resolv], [hstrerror],
AC_SUBST(NEEDS_RESOLV)
test -n "$NEEDS_RESOLV" && LIBS="$LIBS -lresolv"
+AC_CHECK_LIB([gen], [basename],
+[NEEDS_LIBGEN=],
+[NEEDS_LIBGEN=YesPlease])
+AC_SUBST(NEEDS_LIBGEN)
+test -n "$NEEDS_LIBGEN" && LIBS="$LIBS -lgen"
+
## Checks for header files.
AC_MSG_NOTICE([CHECKS for header files])
#