aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStefano Lattarini <stefano.lattarini@gmail.com>2012-03-26 18:42:24 +0200
committerJunio C Hamano <gitster@pobox.com>2012-03-26 12:03:38 -0700
commite9e8c8090e579da5b5f6d2437ecf271568d127ff (patch)
tree387c24623a0a12d43593f87dcc5ee234d43b6d5e /configure.ac
parentb476064544b9a64d062acc5e3c6be831ebb721cb (diff)
downloadgit-e9e8c8090e579da5b5f6d2437ecf271568d127ff.tar.gz
configure: move definitions of private m4 macros before AC_INIT invocation
This way, no spurious comments nor whitespace will be propagated in the generated configure script. This change is a pure code movement (plus addition of a comment line). Signed-off-by: Stefano Lattarini <stefano.lattarini@gmail.com> Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 13 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 72f7958824..0743a70ffe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,18 +1,6 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.59)
-AC_INIT([git], [@@GIT_VERSION@@], [git@vger.kernel.org])
-
-AC_CONFIG_SRCDIR([git.c])
-
-config_file=config.mak.autogen
-config_append=config.mak.append
-config_in=config.mak.in
-
-echo "# ${config_append}. Generated by configure." > "${config_append}"
-
-
## Definitions of macros
# GIT_CONF_APPEND_LINE(LINE)
# --------------------------
@@ -137,6 +125,19 @@ if test -n "$1"; then
fi
])
+## Configure body starts here.
+
+AC_PREREQ(2.59)
+AC_INIT([git], [@@GIT_VERSION@@], [git@vger.kernel.org])
+
+AC_CONFIG_SRCDIR([git.c])
+
+config_file=config.mak.autogen
+config_append=config.mak.append
+config_in=config.mak.in
+
+echo "# ${config_append}. Generated by configure." > "${config_append}"
+
# Directories holding "saner" versions of common or POSIX binaries.
AC_ARG_WITH([sane-tool-path],
[AS_HELP_STRING(