aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Walton <bwalton@artsci.utoronto.ca>2010-01-31 21:15:05 -0500
committerJunio C Hamano <gitster@pobox.com>2010-02-01 13:03:55 -0800
commitdc78250f15a06cc9f31037040517f3a5c85ad470 (patch)
treebab759156c0c786857e13249b685bcc3efe336d3 /configure.ac
parentf22cd7fcc54a98277b3d2b82f1bb0b593658925c (diff)
downloadgit-dc78250f15a06cc9f31037040517f3a5c85ad470.tar.gz
configure: Allow --without-python
This patch allows someone to use configure to build git while at the same time disabling the python remote helper code. It leverages the ability of GIT_ARG_SET_PATH to accept an optional second argument indicating that --without-$PROGRAM is acceptable. Signed-off-by: Ben Walton <bwalton@artsci.utoronto.ca> Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 995abe46dc..e6be739ebf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -288,7 +288,7 @@ GIT_ARG_SET_PATH(shell)
GIT_ARG_SET_PATH(perl)
#
# Define PYTHON_PATH to provide path to Python.
-GIT_ARG_SET_PATH(python)
+GIT_ARG_SET_PATH(python, allow-without)
#
# Define ZLIB_PATH to provide path to zlib.
GIT_ARG_SET_PATH(zlib)