aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDennis Stosberg <dennis@stosberg.net>2006-08-15 11:01:25 +0200
committerJunio C Hamano <junkio@cox.net>2006-08-15 02:57:42 -0700
commitab5573ae9f4178a7b6f6920f04c73a65feb3c690 (patch)
tree78e5aaa651d23b8859e34a77dc919f311ba73c0f /configure.ac
parentf4e14ca9e05876ec1e0d79d7c12b5b3a6b2e9d08 (diff)
downloadgit-ab5573ae9f4178a7b6f6920f04c73a65feb3c690.tar.gz
Look for sockaddr_storage in sys/socket.h
On Solaris and the BSDs the definition of "struct sockaddr_storage" is not available from "netinet/in.h". On Solaris "sys/socket.h" is enough, at least OpenBSD needs "sys/types.h", too. Using "sys/types.h" and "sys/socket.h" seems to be a more portable way. Signed-off-by: Dennis Stosberg <dennis@stosberg.net> Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e890131c46..0321d437d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -181,8 +181,10 @@ AC_SUBST(NO_D_TYPE_IN_DIRENT)
# sockaddr_storage.
AC_CHECK_TYPE(struct sockaddr_storage,
[NO_SOCKADDR_STORAGE=],
-[NO_SOCKADDR_STORAGE=YesPlease],
-[#include <netinet/in.h>])
+[NO_SOCKADDR_STORAGE=YesPlease],[
+#include <sys/types.h>
+#include <sys/socket.h>
+])
AC_SUBST(NO_SOCKADDR_STORAGE)
#
# Define NO_IPV6 if you lack IPv6 support and getaddrinfo().