aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJunio C Hamano <gitster@pobox.com>2009-01-17 23:08:53 -0800
committerJunio C Hamano <gitster@pobox.com>2009-01-17 23:08:53 -0800
commit8b75d31c945c9361331db8cd554f25a8ea6abc4a (patch)
tree8e9653fc89962d66652c5b8d57afe62b81366a6d /configure.ac
parent094f75b4330a68aba7e92b74ddb9282b9f083c6f (diff)
parentd937c374ccb987356c1412986c8fb106b8aaef75 (diff)
downloadgit-8b75d31c945c9361331db8cd554f25a8ea6abc4a.tar.gz
Merge branch 'ds/uintmax-config'
* ds/uintmax-config: autoconf: Enable threaded delta search when pthreads are supported
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0a5fc8c6f6..5198c83f65 100644
--- a/configure.ac
+++ b/configure.ac
@@ -492,7 +492,8 @@ AC_SUBST(NO_MKDTEMP)
#
# Define NO_PTHREADS if we do not have pthreads
#
-# Define PTHREAD_LIBS to the linker flag used for Pthread support.
+# Define PTHREAD_LIBS to the linker flag used for Pthread support and define
+# THREADED_DELTA_SEARCH if Pthreads are available.
AC_LANG_CONFTEST([AC_LANG_PROGRAM(
[[#include <pthread.h>]],
[[pthread_mutex_t test_mutex;]]
@@ -500,16 +501,19 @@ AC_LANG_CONFTEST([AC_LANG_PROGRAM(
${CC} -pthread conftest.c -o conftest.o > /dev/null 2>&1
if test $? -eq 0;then
PTHREAD_LIBS="-pthread"
+ THREADED_DELTA_SEARCH=YesPlease
else
${CC} -lpthread conftest.c -o conftest.o > /dev/null 2>&1
if test $? -eq 0;then
PTHREAD_LIBS="-lpthread"
+ THREADED_DELTA_SEARCH=YesPlease
else
NO_PTHREADS=UnfortunatelyYes
fi
fi
AC_SUBST(PTHREAD_LIBS)
AC_SUBST(NO_PTHREADS)
+AC_SUBST(THREADED_DELTA_SEARCH)
## Site configuration (override autodetection)
## --with-PACKAGE[=ARG] and --without-PACKAGE