aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJakub Narebski <jnareb@gmail.com>2008-01-25 12:19:41 +0100
committerJunio C Hamano <gitster@pobox.com>2008-01-25 22:26:08 -0800
commit3cf3237400f70329525d1085021910b4b76f8670 (patch)
tree7b02f4711460bd73092116c1348d6f6593f28c1a /configure.ac
parent81cc66a526b4d6c74ab7165d13718263c53210ea (diff)
downloadgit-3cf3237400f70329525d1085021910b4b76f8670.tar.gz
autoconf: define NO_SYS_SELECT_H on systems without <sys/select.h>.
Pre-POSIX.1-2001 systems don't have <sys/select.h>, but select(2) is declared in <sys/time.h>, which git-compat-util.h includes. Signed-off-by: Jakub Narebski <jnareb@gmail.com> Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index af177fdb4d..85d7ef570d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -235,6 +235,12 @@ test -n "$NEEDS_SOCKET" && LIBS="$LIBS -lsocket"
## Checks for header files.
AC_MSG_NOTICE([CHECKS for header files])
#
+# Define NO_SYS_SELECT_H if you don't have sys/select.h.
+AC_CHECK_HEADER([sys/select.h],
+[NO_SYS_SELECT_H=],
+[NO_SYS_SELECT_H=UnfortunatelyYes])
+AC_SUBST(NO_SYS_SELECT_H)
+#
# Define OLD_ICONV if your library has an old iconv(), where the second
# (input buffer pointer) parameter is declared with type (const char **).
AC_DEFUN([OLDICONVTEST_SRC], [[