aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid M. Syzdek <david.syzdek@acsalaska.net>2008-10-26 03:52:37 -0800
committerJunio C Hamano <gitster@pobox.com>2008-11-02 01:09:34 -0700
commit0bc3e781deb543ac2042cbd862c035403404c93d (patch)
tree61c10fdd81c3e9bdd840cd736970a8bdc6c8afc3 /configure.ac
parent933bb3ae5e6c83288ec7c80c2282984f4927cb48 (diff)
downloadgit-0bc3e781deb543ac2042cbd862c035403404c93d.tar.gz
Build: add NO_UINTMAX_T to support ancient systems
This adds NO_UINTMAX_T for ancient systems, such as FreeBSD 4.9-SECURITY. If NO_UINTMAX_T is defined, then uintmax_t is defined as uint32_t. Signed-off-by: David M. Syzdek <david.syzdek@acsalaska.net> Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 27bab00a45..a0d53f3124 100644
--- a/configure.ac
+++ b/configure.ac
@@ -436,6 +436,14 @@ AC_CHECK_FUNC(strlcpy,
[NO_STRLCPY=YesPlease])
AC_SUBST(NO_STRLCPY)
#
+# Define NO_UINTMAX_T if your platform does not have uintmax_t
+AC_CHECK_TYPE(uintmax_t,
+[NO_UINTMAX_T=],
+[NO_UINTMAX_T=YesPlease],[
+#include <inttypes.h>
+])
+AC_SUBST(NO_UINTMAX_T)
+#
# Define NO_STRTOUMAX if you don't have strtoumax in the C library.
AC_CHECK_FUNC(strtoumax,
[NO_STRTOUMAX=],