aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarrick J. Wong <djwong@kernel.org>2024-01-09 21:57:24 -0800
committerTheodore Ts'o <tytso@mit.edu>2024-03-28 16:28:08 -0400
commita4c91450875ce6c9bf2aa1c82ccdc75909648f00 (patch)
treef208c81b5ba6668fafb27246d9a028bc2452d36f
parentdf1d5524282987fc5e33f239bcbba187e5431d7c (diff)
downloade2fsprogs-a4c91450875ce6c9bf2aa1c82ccdc75909648f00.tar.gz
debian: don't restart e2scrub_all when upgrading package
When installing or upgrading the e2fsprogs package, only start the e2scrub_all timer and the reaping service. Don't restart e2scrub_all itself, because that will kill any scrubs in progress, which will trigger the failure reporting. Signed-off-by: Darrick J. Wong <djwong@kernel.org> Link: https://lore.kernel.org/r/20240110055724.GC722946@frogsfrogsfrogs Signed-off-by: Theodore Ts'o <tytso@mit.edu>
-rwxr-xr-xdebian/rules4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index b85976f0c..0120fe6aa 100755
--- a/debian/rules
+++ b/debian/rules
@@ -148,6 +148,10 @@ override_dh_installinfo:
dh_installinfo -pcomerr-dev ${stdbuilddir}/lib/et/com_err.info
dh_installinfo -plibext2fs-dev ${stdbuilddir}/doc/libext2fs.info
+override_dh_installsystemd:
+ dh_installsystemd -p e2fsprogs --no-restart-after-upgrade --no-stop-on-upgrade e2scrub_all.timer e2scrub_reap.service
+ dh_installsystemd --name=service1
+
override_dh_makeshlibs:
for i in $(SYMBOL_LIBS); \
do \