aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheodore Ts'o <tytso@mit.edu>2022-08-31 15:45:27 -0400
committerTheodore Ts'o <tytso@mit.edu>2022-08-31 15:45:27 -0400
commit1a9ff1d99bb5c78a12551f835eda6545f123108e (patch)
treeddf0638899cabe93b77a03c1f06823e081d7e155
parent5cc83a2e5d2f3ec19462529c4144a2993b0c86e4 (diff)
downloade2fsprogs-1a9ff1d99bb5c78a12551f835eda6545f123108e.tar.gz
tests/fuzz: add missing targets to the Makefile in in tests/fuzz
This fixes failures when running "make install" or "make destclean" from the top level directory. Signed-off-by: Theodore Ts'o <tytso@mit.edu>
-rw-r--r--tests/fuzz/Makefile.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/fuzz/Makefile.in b/tests/fuzz/Makefile.in
index a6d80639f..949579e7c 100644
--- a/tests/fuzz/Makefile.in
+++ b/tests/fuzz/Makefile.in
@@ -41,6 +41,16 @@ FUZZ_DEP= $(STATIC_DEPLIBS) $(srcdir)/Makefile.in
clean::
$(RM) -f $(PROGS) *.o
+install:
+
+install-strip:
+
+uninstall:
+
+mostlyclean: clean
+distclean: clean
+ $(RM) -f .depend Makefile $(srcdir)/TAGS $(srcdir)/Makefile.in.old
+
ext2fs_check_directory_fuzzer: ext2fs_check_directory_fuzzer.o $(FUZZ_DEP)
$(E) " LD $@"
$(Q) $(CXX) $(FUZZ_LDFLAGS) -o $@ $< $(STATIC_LIBS) $(SYSLIBS)