From: "Eric W. Biederman" , From: "Maciej W. Rozycki" Rename APIC_MODE_EXINT to APIC_MODE_EXTINT - I think it should be named after what the mode is called in documentation. From: "Eric W. Biederman" I have reduced this patch to just the name change in the header. And integrated the changes into the patches that add those lines. Otherwise I ran into some ugly dependencies. Signed-off-by: Maciej W. Rozycki Signed-off-by: Andrew Morton --- 25-akpm/include/asm-i386/apicdef.h | 2 +- 25-akpm/include/asm-x86_64/apicdef.h | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff -puN include/asm-i386/apicdef.h~x86-rename-apic_mode_exint include/asm-i386/apicdef.h --- 25/include/asm-i386/apicdef.h~x86-rename-apic_mode_exint Wed Jan 19 15:22:04 2005 +++ 25-akpm/include/asm-i386/apicdef.h Wed Jan 19 15:22:04 2005 @@ -90,7 +90,7 @@ #define SET_APIC_DELIVERY_MODE(x,y) (((x)&~0x700)|((y)<<8)) #define APIC_MODE_FIXED 0x0 #define APIC_MODE_NMI 0x4 -#define APIC_MODE_EXINT 0x7 +#define APIC_MODE_EXTINT 0x7 #define APIC_LVT1 0x360 #define APIC_LVTERR 0x370 #define APIC_TMICT 0x380 diff -puN include/asm-x86_64/apicdef.h~x86-rename-apic_mode_exint include/asm-x86_64/apicdef.h --- 25/include/asm-x86_64/apicdef.h~x86-rename-apic_mode_exint Wed Jan 19 15:22:04 2005 +++ 25-akpm/include/asm-x86_64/apicdef.h Wed Jan 19 15:22:04 2005 @@ -94,7 +94,7 @@ #define SET_APIC_DELIVERY_MODE(x,y) (((x)&~0x700)|((y)<<8)) #define APIC_MODE_FIXED 0x0 #define APIC_MODE_NMI 0x4 -#define APIC_MODE_EXINT 0x7 +#define APIC_MODE_EXTINT 0x7 #define APIC_LVT1 0x360 #define APIC_LVTERR 0x370 #define APIC_TMICT 0x380 _