€•ùŒsphinx.addnodes”Œdocument”“”)�”}”(Œ rawsource”Œ”Œchildren”]”(Œ translations”Œ LanguagesNode”“”)�”}”(hhh]”(hŒ pending_xref”“”)�”}”(hhh]”Œdocutils.nodes”ŒText”“”ŒChinese (Simplified)”…”�”}”Œparent”hsbaŒ attributes”}”(Œids”]”Œclasses”]”Œnames”]”Œdupnames”]”Œbackrefs”]”Œ refdomain”Œstd”Œreftype”Œdoc”Œ reftarget”Œ%/translations/zh_CN/networking/arcnet”Œmodname”NŒ classname”NŒ refexplicit”ˆuŒtagname”hhh ubh)�”}”(hhh]”hŒChinese (Traditional)”…”�”}”hh2sbah}”(h]”h ]”h"]”h$]”h&]”Œ refdomain”h)Œreftype”h+Œ reftarget”Œ%/translations/zh_TW/networking/arcnet”Œmodname”NŒ classname”NŒ refexplicit”ˆuh1hhh ubh)�”}”(hhh]”hŒItalian”…”�”}”hhFsbah}”(h]”h ]”h"]”h$]”h&]”Œ refdomain”h)Œreftype”h+Œ reftarget”Œ%/translations/it_IT/networking/arcnet”Œmodname”NŒ classname”NŒ refexplicit”ˆuh1hhh ubh)�”}”(hhh]”hŒJapanese”…”�”}”hhZsbah}”(h]”h ]”h"]”h$]”h&]”Œ refdomain”h)Œreftype”h+Œ reftarget”Œ%/translations/ja_JP/networking/arcnet”Œmodname”NŒ classname”NŒ refexplicit”ˆuh1hhh ubh)�”}”(hhh]”hŒKorean”…”�”}”hhnsbah}”(h]”h ]”h"]”h$]”h&]”Œ refdomain”h)Œreftype”h+Œ reftarget”Œ%/translations/ko_KR/networking/arcnet”Œmodname”NŒ classname”NŒ refexplicit”ˆuh1hhh ubh)�”}”(hhh]”hŒPortuguese (Brazilian)”…”�”}”hh‚sbah}”(h]”h ]”h"]”h$]”h&]”Œ refdomain”h)Œreftype”h+Œ reftarget”Œ%/translations/pt_BR/networking/arcnet”Œmodname”NŒ classname”NŒ refexplicit”ˆuh1hhh ubh)�”}”(hhh]”hŒSpanish”…”�”}”hh–sbah}”(h]”h ]”h"]”h$]”h&]”Œ refdomain”h)Œreftype”h+Œ reftarget”Œ%/translations/sp_SP/networking/arcnet”Œmodname”NŒ classname”NŒ refexplicit”ˆuh1hhh ubeh}”(h]”h ]”h"]”h$]”h&]”Œcurrent_language”ŒEnglish”uh1h hhŒ _document”hŒsource”NŒline”NubhŒcomment”“”)�”}”(hŒ SPDX-License-Identifier: GPL-2.0”h]”hŒ SPDX-License-Identifier: GPL-2.0”…”�”}”hh·sbah}”(h]”h ]”h"]”h$]”h&]”Œ xml:space”Œpreserve”uh1hµhhh²hh³Œ?/var/lib/git/docbuild/linux/Documentation/networking/arcnet.rst”h´KubhŒsection”“”)�”}”(hhh]”(hŒtitle”“”)�”}”(hŒARCnet”h]”hŒARCnet”…”�”}”(hhÏh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hÍhhÊh²hh³hÇh´KubhŒ field_list”“”)�”}”(hhh]”hŒfield”“”)�”}”(hhh]”(hŒ field_name”“”)�”}”(hŒAuthor”h]”hŒAuthor”…”�”}”(hhéh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hçhhäh³hÇh´KubhŒ field_body”“”)�”}”(hŒ*Avery Pennarun ”h]”hŒ paragraph”“”)�”}”(hŒ)Avery Pennarun ”h]”(hŒAvery Pennarun <”…”�”}”(hhÿh²hh³Nh´NubhŒ reference”“”)�”}”(hŒapenwarr@worldvisions.ca”h]”hŒapenwarr@worldvisions.ca”…”�”}”(hj h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”Œrefuri”Œmailto:apenwarr@worldvisions.ca”uh1jhhÿubhŒ>”…”�”}”(hhÿh²hh³Nh´Nubeh}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Khhùubah}”(h]”h ]”h"]”h$]”h&]”uh1h÷hhäubeh}”(h]”h ]”h"]”h$]”h&]”uh1hâh³hÇh´Khhßh²hubah}”(h]”h ]”h"]”h$]”h&]”uh1hÝhhÊh²hh³hÇh´KubhŒnote”“”)�”}”(hŒ¬See also arcnet-hardware.rst in this directory for jumper-setting and cabling information if you're like many of us and didn't happen to get a manual with your ARCnet card.”h]”hþ)�”}”(hŒ¬See also arcnet-hardware.rst in this directory for jumper-setting and cabling information if you're like many of us and didn't happen to get a manual with your ARCnet card.”h]”hŒ°See also arcnet-hardware.rst in this directory for jumper-setting and cabling information if you’re like many of us and didn’t happen to get a manual with your ARCnet card.”…”�”}”(hj;h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K hj7ubah}”(h]”h ]”h"]”h$]”h&]”uh1j5hhÊh²hh³hÇh´NubhŒ transition”“”)�”}”(hŒ----”h]”h}”(h]”h ]”h"]”h$]”h&]”uh1jOh³hÇh´KhhÊh²hubhþ)�”}”(hŒ'These are the ARCnet drivers for Linux.”h]”hŒ'These are the ARCnet drivers for Linux.”…”�”}”(hj[h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KhhÊh²hubhþ)�”}”(hX­This new release (2.91) has been put together by David Woodhouse , in an attempt to tidy up the driver after adding support for yet another chipset. Now the generic support has been separated from the individual chipset drivers, and the source files aren't quite so packed with #ifdefs! I've changed this file a bit, but kept it in the first person from Avery, because I didn't want to completely rewrite it.”h]”(hŒBThis new release (2.91) has been put together by David Woodhouse <”…”�”}”(hjih²hh³Nh´Nubj)�”}”(hŒdwmw2@infradead.org”h]”hŒdwmw2@infradead.org”…”�”}”(hjqh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”Œrefuri”Œmailto:dwmw2@infradead.org”uh1jhjiubhX^>, in an attempt to tidy up the driver after adding support for yet another chipset. Now the generic support has been separated from the individual chipset drivers, and the source files aren’t quite so packed with #ifdefs! I’ve changed this file a bit, but kept it in the first person from Avery, because I didn’t want to completely rewrite it.”…”�”}”(hjih²hh³Nh´Nubeh}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KhhÊh²hubhþ)�”}”(hXUThe previous release resulted from many months of on-and-off effort from me (Avery Pennarun), many bug reports/fixes and suggestions from others, and in particular a lot of input and coding from Tomasz Motylewski. Starting with ARCnet 2.10 ALPHA, Tomasz's all-new-and-improved RFC1051 support has been included and seems to be working fine!”h]”hXWThe previous release resulted from many months of on-and-off effort from me (Avery Pennarun), many bug reports/fixes and suggestions from others, and in particular a lot of input and coding from Tomasz Motylewski. Starting with ARCnet 2.10 ALPHA, Tomasz’s all-new-and-improved RFC1051 support has been included and seems to be working fine!”…”�”}”(hj‹h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KhhÊh²hubhŒtarget”“”)�”}”(hŒ.. _arcnet-netdev:”h]”h}”(h]”h ]”h"]”h$]”h&]”Œrefid”Œ arcnet-netdev”uh1j™h´K!hhÊh²hh³hÇubhÉ)�”}”(hhh]”(hÎ)�”}”(hŒ!Where do I discuss these drivers?”h]”hŒ!Where do I discuss these drivers?”…”�”}”(hjªh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hÍhj§h²hh³hÇh´K$ubhþ)�”}”(hŒÌARCnet discussions take place on netdev. Simply send your email to netdev@vger.kernel.org and make sure to Cc: maintainer listed in "ARCNET NETWORK LAYER" heading of Documentation/process/maintainers.rst.”h]”(hŒCARCnet discussions take place on netdev. Simply send your email to ”…”�”}”(hj¸h²hh³Nh´Nubj)�”}”(hŒnetdev@vger.kernel.org”h]”hŒnetdev@vger.kernel.org”…”�”}”(hjÀh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”Œrefuri”Œmailto:netdev@vger.kernel.org”uh1jhj¸ubhŒw and make sure to Cc: maintainer listed in “ARCNET NETWORK LAYERâ€� heading of Documentation/process/maintainers.rst.”…”�”}”(hj¸h²hh³Nh´Nubeh}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K&hj§h²hubeh}”(h]”(Œ where-do-i-discuss-these-drivers”j¦eh ]”h"]”(Œ!where do i discuss these drivers?”Œ arcnet-netdev”eh$]”h&]”uh1hÈhhÊh²hh³hÇh´K$Œexpect_referenced_by_name”}”jàj›sŒexpect_referenced_by_id”}”j¦j›subhÉ)�”}”(hhh]”(hÎ)�”}”(hŒOther Drivers and Info”h]”hŒOther Drivers and Info”…”�”}”(hjêh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hÍhjçh²hh³hÇh´K+ubhþ)�”}”(hŒBYou can try JoAnne Schmitz's ARCNET page on the World Wide Web at:”h]”hŒDYou can try JoAnne Schmitz’s ARCNET page on the World Wide Web at:”…”�”}”(hjøh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K-hjçh²hubhŒ block_quote”“”)�”}”(hŒ'https://www.qis.net/~jschmitz/arcnet/ ”h]”hþ)�”}”(hŒ%https://www.qis.net/~jschmitz/arcnet/”h]”j)�”}”(hjh]”hŒ%https://www.qis.net/~jschmitz/arcnet/”…”�”}”(hjh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”Œrefuri”juh1jhj ubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K/hjubah}”(h]”h ]”h"]”h$]”h&]”uh1jh³hÇh´K/hjçh²hubeh}”(h]”Œother-drivers-and-info”ah ]”h"]”Œother drivers and info”ah$]”h&]”uh1hÈhhÊh²hh³hÇh´K+ubhÉ)�”}”(hhh]”(hÎ)�”}”(hŒSupported Hardware”h]”hŒSupported Hardware”…”�”}”(hj5h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hÍhj2h²hh³hÇh´K3ubhþ)�”}”(hŒôOnly PCI and PCI Express devices based on the COM20020 chipset are supported. This is the newest chipset from SMC with support for promiscuous mode (packet sniffing), extra diagnostic information, etc. These devices use the com20020_pci driver.”h]”hŒôOnly PCI and PCI Express devices based on the COM20020 chipset are supported. This is the newest chipset from SMC with support for promiscuous mode (packet sniffing), extra diagnostic information, etc. These devices use the com20020_pci driver.”…”�”}”(hjCh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K5hj2h²hubhþ)�”}”(hŒdSupport for older chipsets and ISA and PCMCIA devices was previously available but has been removed.”h]”hŒdSupport for older chipsets and ISA and PCMCIA devices was previously available but has been removed.”…”�”}”(hjQh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K:hj2h²hubeh}”(h]”Œsupported-hardware”ah ]”h"]”Œsupported hardware”ah$]”h&]”uh1hÈhhÊh²hh³hÇh´K3ubhÉ)�”}”(hhh]”(hÎ)�”}”(hŒConfiguring the Driver”h]”hŒConfiguring the Driver”…”�”}”(hjjh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hÍhjgh²hh³hÇh´K?ubhþ)�”}”(hŒYThe COM20020 driver will be loaded automatically at boot if a supported card is detected.”h]”hŒYThe COM20020 driver will be loaded automatically at boot if a supported card is detected.”…”�”}”(hjxh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KAhjgh²hubhþ)�”}”(hŒOIf the com20020_pci driver was compiled as a loadable module, the options are::”h]”hŒNIf the com20020_pci driver was compiled as a loadable module, the options are:”…”�”}”(hj†h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KDhjgh²hubhŒ literal_block”“”)�”}”(hŒhnode= backplane= clockp= clockm= timeout= device=”h]”hŒhnode= backplane= clockp= clockm= timeout= device=”…”�”}”hj–sbah}”(h]”h ]”h"]”h$]”h&]”hÅhÆuh1j”h³hÇh´KFhjgh²hubhþ)�”}”(hŒ®If the driver was compiled into the kernel, the same options can be specified on the kernel command line by prefixing them with `com20020_pci.`, as in the following example::”h]”(hŒ€If the driver was compiled into the kernel, the same options can be specified on the kernel command line by prefixing them with ”…”�”}”(hj¤h²hh³Nh´NubhŒtitle_reference”“”)�”}”(hŒ`com20020_pci.`”h]”hŒ com20020_pci.”…”�”}”(hj®h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1j¬hj¤ubhŒ, as in the following example:”…”�”}”(hj¤h²hh³Nh´Nubeh}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KIhjgh²hubj•)�”}”(hŒcom20020_pci.device=eth1”h]”hŒcom20020_pci.device=eth1”…”�”}”hjÆsbah}”(h]”h ]”h"]”h$]”h&]”hÅhÆuh1j”h³hÇh´KMhjgh²hubhþ)�”}”(hXThe COM20020 chipset allows you to set the node ID in software, overriding the default which is still set in DIP switches on the card. If you don't have the COM20020 data sheets, and you don't know what the other options refer to, then they won't interest you - forget them.”h]”hXThe COM20020 chipset allows you to set the node ID in software, overriding the default which is still set in DIP switches on the card. If you don’t have the COM20020 data sheets, and you don’t know what the other options refer to, then they won’t interest you - forget them.”…”�”}”(hjÔh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KOhjgh²hubhþ)�”}”(hŒ‚Otherwise, ARCnet can be configured in a similar way to Ethernet, with the exception that ARCnet interface names begin with `arc`.”h]”(hŒ|Otherwise, ARCnet can be configured in a similar way to Ethernet, with the exception that ARCnet interface names begin with ”…”�”}”(hjâh²hh³Nh´Nubj­)�”}”(hŒ`arc`”h]”hŒarc”…”�”}”(hjêh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1j¬hjâubhŒ.”…”�”}”(hjâh²hh³Nh´Nubeh}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KThjgh²hubeh}”(h]”Œconfiguring-the-driver”ah ]”h"]”Œconfiguring the driver”ah$]”h&]”uh1hÈhhÊh²hh³hÇh´K?ubhÉ)�”}”(hhh]”(hÎ)�”}”(hŒ How do I get it to work with...?”h]”hŒ How do I get it to work with...?”…”�”}”(hj h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hÍhj h²hh³hÇh´KYubhŒdefinition_list”“”)�”}”(hhh]”(hŒdefinition_list_item”“”)�”}”(hX™NFS: Should be fine linux->linux, just pretend you're using Ethernet cards. oak.oakland.edu:/simtel/msdos/nfs has some nice DOS clients. There is also a DOS-based NFS server called SOSS. It doesn't multitask quite the way Linux does (actually, it doesn't multitask AT ALL) but you never know what you might need. With AmiTCP (and possibly others), you may need to set the following options in your Amiga nfstab: MD 1024 MR 1024 MW 1024 (Thanks to Christian Gottschling for this.) Probably these refer to maximum NFS data/read/write block sizes. I don't know why the defaults on the Amiga didn't work; write to me if you know more. ”h]”(hŒterm”“”)�”}”(hŒNFS:”h]”hŒNFS:”…”�”}”(hj(h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1j&h³hÇh´Kihj"ubhŒ definition”“”)�”}”(hhh]”(hþ)�”}”(hX5Should be fine linux->linux, just pretend you're using Ethernet cards. oak.oakland.edu:/simtel/msdos/nfs has some nice DOS clients. There is also a DOS-based NFS server called SOSS. It doesn't multitask quite the way Linux does (actually, it doesn't multitask AT ALL) but you never know what you might need.”h]”hX;Should be fine linux->linux, just pretend you’re using Ethernet cards. oak.oakland.edu:/simtel/msdos/nfs has some nice DOS clients. There is also a DOS-based NFS server called SOSS. It doesn’t multitask quite the way Linux does (actually, it doesn’t multitask AT ALL) but you never know what you might need.”…”�”}”(hj;h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K\hj8ubhþ)�”}”(hŒÃWith AmiTCP (and possibly others), you may need to set the following options in your Amiga nfstab: MD 1024 MR 1024 MW 1024 (Thanks to Christian Gottschling for this.)”h]”(hŒžWith AmiTCP (and possibly others), you may need to set the following options in your Amiga nfstab: MD 1024 MR 1024 MW 1024 (Thanks to Christian Gottschling <”…”�”}”(hjIh²hh³Nh´Nubj)�”}”(hŒferksy@indigo.tng.oche.de”h]”hŒferksy@indigo.tng.oche.de”…”�”}”(hjQh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”Œrefuri”Œ mailto:ferksy@indigo.tng.oche.de”uh1jhjIubhŒ > for this.)”…”�”}”(hjIh²hh³Nh´Nubeh}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Kbhj8ubhþ)�”}”(hŒ—Probably these refer to maximum NFS data/read/write block sizes. I don't know why the defaults on the Amiga didn't work; write to me if you know more.”h]”hŒ›Probably these refer to maximum NFS data/read/write block sizes. I don’t know why the defaults on the Amiga didn’t work; write to me if you know more.”…”�”}”(hjkh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Kghj8ubeh}”(h]”h ]”h"]”h$]”h&]”uh1j6hj"ubeh}”(h]”h ]”h"]”h$]”h&]”uh1j h³hÇh´Kihjubj!)�”}”(hXDOS: If you're using the freeware arcether.com, you might want to install the driver patch from my web page. It helps with PC/TCP, and also can get arcether to load if it timed out too quickly during initialization. In fact, if you use it on a 386+ you REALLY need the patch, really. ”h]”(j')�”}”(hŒDOS:”h]”hŒDOS:”…”�”}”(hj‰h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1j&h³hÇh´Kphj…ubj7)�”}”(hhh]”hþ)�”}”(hXIf you're using the freeware arcether.com, you might want to install the driver patch from my web page. It helps with PC/TCP, and also can get arcether to load if it timed out too quickly during initialization. In fact, if you use it on a 386+ you REALLY need the patch, really.”h]”hXIf you’re using the freeware arcether.com, you might want to install the driver patch from my web page. It helps with PC/TCP, and also can get arcether to load if it timed out too quickly during initialization. In fact, if you use it on a 386+ you REALLY need the patch, really.”…”�”}”(hjšh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Klhj—ubah}”(h]”h ]”h"]”h$]”h&]”uh1j6hj…ubeh}”(h]”h ]”h"]”h$]”h&]”uh1j h³hÇh´Kphjh²hubj!)�”}”(hŒ‹Windows: See DOS :) Trumpet Winsock works fine with either the Novell or Arcether client, assuming you remember to load winpkt of course. ”h]”(j')�”}”(hŒWindows:”h]”hŒWindows:”…”�”}”(hj¸h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1j&h³hÇh´Kthj´ubj7)�”}”(hhh]”hþ)�”}”(hŒ�See DOS :) Trumpet Winsock works fine with either the Novell or Arcether client, assuming you remember to load winpkt of course.”h]”hŒ�See DOS :) Trumpet Winsock works fine with either the Novell or Arcether client, assuming you remember to load winpkt of course.”…”�”}”(hjÉh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KshjÆubah}”(h]”h ]”h"]”h$]”h&]”uh1j6hj´ubeh}”(h]”h ]”h"]”h$]”h&]”uh1j h³hÇh´Kthjh²hubj!)�”}”(hXâLAN Manager and Windows for Workgroups: These programs use protocols that are incompatible with the Internet standard. They try to pretend the cards are Ethernet, and confuse everyone else on the network. The Linux ARCnet driver supports this protocol via the 'arc0e' device. See the section on "Multiprotocol Support" for more information. Using the freeware Samba server and clients for Linux, you can now interface quite nicely with TCP/IP-based WfWg or Lan Manager networks. ”h]”(j')�”}”(hŒ'LAN Manager and Windows for Workgroups:”h]”hŒ'LAN Manager and Windows for Workgroups:”…”�”}”(hjçh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1j&h³hÇh´K€hjãubj7)�”}”(hhh]”(hþ)�”}”(hŒ¥These programs use protocols that are incompatible with the Internet standard. They try to pretend the cards are Ethernet, and confuse everyone else on the network.”h]”hŒ¥These programs use protocols that are incompatible with the Internet standard. They try to pretend the cards are Ethernet, and confuse everyone else on the network.”…”�”}”(hjøh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Kwhjõubhþ)�”}”(hŒ‡The Linux ARCnet driver supports this protocol via the 'arc0e' device. See the section on "Multiprotocol Support" for more information.”h]”hŒ�The Linux ARCnet driver supports this protocol via the ‘arc0e’ device. See the section on “Multiprotocol Supportâ€� for more information.”…”�”}”(hjh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K{hjõubhþ)�”}”(hŒ‰Using the freeware Samba server and clients for Linux, you can now interface quite nicely with TCP/IP-based WfWg or Lan Manager networks.”h]”hŒ‰Using the freeware Samba server and clients for Linux, you can now interface quite nicely with TCP/IP-based WfWg or Lan Manager networks.”…”�”}”(hjh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K~hjõubeh}”(h]”h ]”h"]”h$]”h&]”uh1j6hjãubeh}”(h]”h ]”h"]”h$]”h&]”uh1j h³hÇh´K€hjh²hubj!)�”}”(hXÆWindows 95: Tools are included with Win95 that let you use either the LANMAN style network drivers (NDIS) or Novell drivers (ODI) to handle your ARCnet packets. If you use ODI, you'll need to use the 'arc0' device with Linux. If you use NDIS, then try the 'arc0e' device. See the "Multiprotocol Support" section below if you need arc0e, you're completely insane, and/or you need to build some kind of hybrid network that uses both encapsulation types. ”h]”(j')�”}”(hŒ Windows 95:”h]”hŒ Windows 95:”…”�”}”(hj2h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1j&h³hÇh´K‰hj.ubj7)�”}”(hhh]”hþ)�”}”(hX¹Tools are included with Win95 that let you use either the LANMAN style network drivers (NDIS) or Novell drivers (ODI) to handle your ARCnet packets. If you use ODI, you'll need to use the 'arc0' device with Linux. If you use NDIS, then try the 'arc0e' device. See the "Multiprotocol Support" section below if you need arc0e, you're completely insane, and/or you need to build some kind of hybrid network that uses both encapsulation types.”h]”hXÉTools are included with Win95 that let you use either the LANMAN style network drivers (NDIS) or Novell drivers (ODI) to handle your ARCnet packets. If you use ODI, you’ll need to use the ‘arc0’ device with Linux. If you use NDIS, then try the ‘arc0e’ device. See the “Multiprotocol Supportâ€� section below if you need arc0e, you’re completely insane, and/or you need to build some kind of hybrid network that uses both encapsulation types.”…”�”}”(hjCh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Kƒhj@ubah}”(h]”h ]”h"]”h$]”h&]”uh1j6hj.ubeh}”(h]”h ]”h"]”h$]”h&]”uh1j h³hÇh´K‰hjh²hubj!)�”}”(hX¼OS/2: I've been told it works under Warp Connect with an ARCnet driver from SMC. You need to use the 'arc0e' interface for this. If you get the SMC driver to work with the TCP/IP stuff included in the "normal" Warp Bonus Pack, let me know. ftp.microsoft.com also has a freeware "Lan Manager for OS/2" client which should use the same protocol as WfWg does. I had no luck installing it under Warp, however. Please mail me with any results. ”h]”(j')�”}”(hŒOS/2:”h]”hŒOS/2:”…”�”}”(hjah²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1j&h³hÇh´K“hj]ubj7)�”}”(hhh]”(hþ)�”}”(hŒëI've been told it works under Warp Connect with an ARCnet driver from SMC. You need to use the 'arc0e' interface for this. If you get the SMC driver to work with the TCP/IP stuff included in the "normal" Warp Bonus Pack, let me know.”h]”hŒõI’ve been told it works under Warp Connect with an ARCnet driver from SMC. You need to use the ‘arc0e’ interface for this. If you get the SMC driver to work with the TCP/IP stuff included in the “normalâ€� Warp Bonus Pack, let me know.”…”�”}”(hjrh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KŒhjoubhþ)�”}”(hŒÈftp.microsoft.com also has a freeware "Lan Manager for OS/2" client which should use the same protocol as WfWg does. I had no luck installing it under Warp, however. Please mail me with any results.”h]”hŒÌftp.microsoft.com also has a freeware “Lan Manager for OS/2â€� client which should use the same protocol as WfWg does. I had no luck installing it under Warp, however. Please mail me with any results.”…”�”}”(hj€h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K‘hjoubeh}”(h]”h ]”h"]”h$]”h&]”uh1j6hj]ubeh}”(h]”h ]”h"]”h$]”h&]”uh1j h³hÇh´K“hjh²hubj!)�”}”(hXNetBSD/AmiTCP: These use an old version of the Internet standard ARCnet protocol (RFC1051) which is compatible with the Linux driver v2.10 ALPHA and above using the arc0s device. (See "Multiprotocol ARCnet" below.) ** Newer versions of NetBSD apparently support RFC1201. ”h]”(j')�”}”(hŒNetBSD/AmiTCP:”h]”hŒNetBSD/AmiTCP:”…”�”}”(hjžh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1j&h³hÇh´Kšhjšubj7)�”}”(hhh]”hþ)�”}”(hXThese use an old version of the Internet standard ARCnet protocol (RFC1051) which is compatible with the Linux driver v2.10 ALPHA and above using the arc0s device. (See "Multiprotocol ARCnet" below.) ** Newer versions of NetBSD apparently support RFC1201.”h]”hXThese use an old version of the Internet standard ARCnet protocol (RFC1051) which is compatible with the Linux driver v2.10 ALPHA and above using the arc0s device. (See “Multiprotocol ARCnetâ€� below.) ** Newer versions of NetBSD apparently support RFC1201.”…”�”}”(hj¯h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K–hj¬ubah}”(h]”h ]”h"]”h$]”h&]”uh1j6hjšubeh}”(h]”h ]”h"]”h$]”h&]”uh1j h³hÇh´Kšhjh²hubeh}”(h]”h ]”h"]”h$]”h&]”uh1jhj h²hh³hÇh´Nubeh}”(h]”Œhow-do-i-get-it-to-work-with”ah ]”h"]”Œ how do i get it to work with...?”ah$]”h&]”uh1hÈhhÊh²hh³hÇh´KYubhÉ)�”}”(hhh]”(hÎ)�”}”(hŒUsing Multiprotocol ARCnet”h]”hŒUsing Multiprotocol ARCnet”…”�”}”(hjÚh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hÍhj×h²hh³hÇh´K�ubhþ)�”}”(hŒUThe ARCnet driver supports three protocols, each on its own "virtual network device":”h]”hŒYThe ARCnet driver supports three protocols, each on its own “virtual network deviceâ€�:”…”�”}”(hjèh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KŸhj×h²hubj)�”}”(hXY====== =============================================================== arc0 RFC1201 protocol, the official Internet standard which just happens to be 100% compatible with Novell's TRXNET driver. Version 1.00 of the ARCnet driver supported _only_ this protocol. arc0 is the fastest of the three protocols (for whatever reason), and allows larger packets to be used because it supports RFC1201 "packet splitting" operations. Unless you have a specific need to use a different protocol, I strongly suggest that you stick with this one. arc0e "Ethernet-Encapsulation" which sends packets over ARCnet that are actually a lot like Ethernet packets, including the 6-byte hardware addresses. This protocol is compatible with Microsoft's NDIS ARCnet driver, like the one in WfWg and LANMAN. Because the MTU of 493 is actually smaller than the one "required" by TCP/IP (576), there is a chance that some network operations will not function properly. The Linux TCP/IP layer can compensate in most cases, however, by automatically fragmenting the TCP/IP packets to make them fit. arc0e also works slightly more slowly than arc0, for reasons yet to be determined. (Probably it's the smaller MTU that does it.) arc0s The "[s]imple" RFC1051 protocol is the "previous" Internet standard that is completely incompatible with the new standard. Some software today, however, continues to support the old standard (and only the old standard) including NetBSD and AmiTCP. RFC1051 also does not support RFC1201's packet splitting, and the MTU of 507 is still smaller than the Internet "requirement," so it's quite possible that you may run into problems. It's also slower than RFC1201 by about 25%, for the same reason as arc0e. The arc0s support was contributed by Tomasz Motylewski and modified somewhat by me. Bugs are probably my fault. ====== =============================================================== ”h]”hŒtable”“”)�”}”(hhh]”hŒtgroup”“”)�”}”(hhh]”(hŒcolspec”“”)�”}”(hhh]”h}”(h]”h ]”h"]”h$]”h&]”Œcolwidth”Kuh1jhjubj)�”}”(hhh]”h}”(h]”h ]”h"]”h$]”h&]”Œcolwidth”K?uh1jhjubhŒtbody”“”)�”}”(hhh]”(hŒrow”“”)�”}”(hhh]”(hŒentry”“”)�”}”(hhh]”hþ)�”}”(hŒarc0”h]”hŒarc0”…”�”}”(hj)h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K£hj&ubah}”(h]”h ]”h"]”h$]”h&]”uh1j$hj!ubj%)�”}”(hhh]”hþ)�”}”(hXÉRFC1201 protocol, the official Internet standard which just happens to be 100% compatible with Novell's TRXNET driver. Version 1.00 of the ARCnet driver supported _only_ this protocol. arc0 is the fastest of the three protocols (for whatever reason), and allows larger packets to be used because it supports RFC1201 "packet splitting" operations. Unless you have a specific need to use a different protocol, I strongly suggest that you stick with this one.”h]”hXÏRFC1201 protocol, the official Internet standard which just happens to be 100% compatible with Novell’s TRXNET driver. Version 1.00 of the ARCnet driver supported _only_ this protocol. arc0 is the fastest of the three protocols (for whatever reason), and allows larger packets to be used because it supports RFC1201 “packet splittingâ€� operations. Unless you have a specific need to use a different protocol, I strongly suggest that you stick with this one.”…”�”}”(hj@h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K£hj=ubah}”(h]”h ]”h"]”h$]”h&]”uh1j$hj!ubeh}”(h]”h ]”h"]”h$]”h&]”uh1jhjubj )�”}”(hhh]”(j%)�”}”(hhh]”hþ)�”}”(hŒarc0e”h]”hŒarc0e”…”�”}”(hj`h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K¬hj]ubah}”(h]”h ]”h"]”h$]”h&]”uh1j$hjZubj%)�”}”(hhh]”hþ)�”}”(hX—"Ethernet-Encapsulation" which sends packets over ARCnet that are actually a lot like Ethernet packets, including the 6-byte hardware addresses. This protocol is compatible with Microsoft's NDIS ARCnet driver, like the one in WfWg and LANMAN. Because the MTU of 493 is actually smaller than the one "required" by TCP/IP (576), there is a chance that some network operations will not function properly. The Linux TCP/IP layer can compensate in most cases, however, by automatically fragmenting the TCP/IP packets to make them fit. arc0e also works slightly more slowly than arc0, for reasons yet to be determined. (Probably it's the smaller MTU that does it.)”h]”hX£“Ethernet-Encapsulationâ€� which sends packets over ARCnet that are actually a lot like Ethernet packets, including the 6-byte hardware addresses. This protocol is compatible with Microsoft’s NDIS ARCnet driver, like the one in WfWg and LANMAN. Because the MTU of 493 is actually smaller than the one “requiredâ€� by TCP/IP (576), there is a chance that some network operations will not function properly. The Linux TCP/IP layer can compensate in most cases, however, by automatically fragmenting the TCP/IP packets to make them fit. arc0e also works slightly more slowly than arc0, for reasons yet to be determined. (Probably it’s the smaller MTU that does it.)”…”�”}”(hjwh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K¬hjtubah}”(h]”h ]”h"]”h$]”h&]”uh1j$hjZubeh}”(h]”h ]”h"]”h$]”h&]”uh1jhjubj )�”}”(hhh]”(j%)�”}”(hhh]”hþ)�”}”(hŒarc0s”h]”hŒarc0s”…”�”}”(hj—h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K¹hj”ubah}”(h]”h ]”h"]”h$]”h&]”uh1j$hj‘ubj%)�”}”(hhh]”(hþ)�”}”(hXúThe "[s]imple" RFC1051 protocol is the "previous" Internet standard that is completely incompatible with the new standard. Some software today, however, continues to support the old standard (and only the old standard) including NetBSD and AmiTCP. RFC1051 also does not support RFC1201's packet splitting, and the MTU of 507 is still smaller than the Internet "requirement," so it's quite possible that you may run into problems. It's also slower than RFC1201 by about 25%, for the same reason as arc0e.”h]”hX The “[s]impleâ€� RFC1051 protocol is the “previousâ€� Internet standard that is completely incompatible with the new standard. Some software today, however, continues to support the old standard (and only the old standard) including NetBSD and AmiTCP. RFC1051 also does not support RFC1201’s packet splitting, and the MTU of 507 is still smaller than the Internet “requirement,â€� so it’s quite possible that you may run into problems. It’s also slower than RFC1201 by about 25%, for the same reason as arc0e.”…”�”}”(hj®h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´K¹hj«ubhþ)�”}”(hŒpThe arc0s support was contributed by Tomasz Motylewski and modified somewhat by me. Bugs are probably my fault.”h]”hŒpThe arc0s support was contributed by Tomasz Motylewski and modified somewhat by me. Bugs are probably my fault.”…”�”}”(hj¼h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KÃhj«ubeh}”(h]”h ]”h"]”h$]”h&]”uh1j$hj‘ubeh}”(h]”h ]”h"]”h$]”h&]”uh1jhjubeh}”(h]”h ]”h"]”h$]”h&]”uh1jhjubeh}”(h]”h ]”h"]”h$]”h&]”Œcols”Kuh1jÿhjüubah}”(h]”h ]”h"]”h$]”h&]”uh1júhjöubah}”(h]”h ]”h"]”h$]”h&]”uh1jh³hÇh´K¢hj×h²hubhþ)�”}”(hŒÇYou can choose not to compile arc0e and arc0s into the driver if you want - this will save you a bit of memory and avoid confusion when eg. trying to use the "NFS-root" stuff in recent Linux kernels.”h]”hŒËYou can choose not to compile arc0e and arc0s into the driver if you want - this will save you a bit of memory and avoid confusion when eg. trying to use the “NFS-rootâ€� stuff in recent Linux kernels.”…”�”}”(hjïh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KÇhj×h²hubhþ)�”}”(hŒùThe arc0e and arc0s devices are created automatically when you first ifconfig the arc0 device. To actually use them, though, you need to also ifconfig the other virtual devices you need. There are a number of ways you can set up your network then:”h]”hŒùThe arc0e and arc0s devices are created automatically when you first ifconfig the arc0 device. To actually use them, though, you need to also ifconfig the other virtual devices you need. There are a number of ways you can set up your network then:”…”�”}”(hjýh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KËhj×h²hubhŒenumerated_list”“”)�”}”(hhh]”(hŒ list_item”“”)�”}”(hXæSingle Protocol. This is the simplest way to configure your network: use just one of the two available protocols. As mentioned above, it's a good idea to use only arc0 unless you have a good reason (like some other software, ie. WfWg, that only works with arc0e). If you need only arc0, then the following commands should get you going:: ifconfig arc0 MY.IP.ADD.RESS route add MY.IP.ADD.RESS arc0 route add -net SUB.NET.ADD.RESS arc0 [add other local routes here] If you need arc0e (and only arc0e), it's a little different:: ifconfig arc0 MY.IP.ADD.RESS ifconfig arc0e MY.IP.ADD.RESS route add MY.IP.ADD.RESS arc0e route add -net SUB.NET.ADD.RESS arc0e arc0s works much the same way as arc0e. ”h]”(hþ)�”}”(hŒSingle Protocol.”h]”hŒSingle Protocol.”…”�”}”(hjh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KÑhjubhþ)�”}”(hŒ÷This is the simplest way to configure your network: use just one of the two available protocols. As mentioned above, it's a good idea to use only arc0 unless you have a good reason (like some other software, ie. WfWg, that only works with arc0e).”h]”hŒùThis is the simplest way to configure your network: use just one of the two available protocols. As mentioned above, it’s a good idea to use only arc0 unless you have a good reason (like some other software, ie. WfWg, that only works with arc0e).”…”�”}”(hj$h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KÓhjubhþ)�”}”(hŒIIf you need only arc0, then the following commands should get you going::”h]”hŒHIf you need only arc0, then the following commands should get you going:”…”�”}”(hj2h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´KØhjubj•)�”}”(hŒ}ifconfig arc0 MY.IP.ADD.RESS route add MY.IP.ADD.RESS arc0 route add -net SUB.NET.ADD.RESS arc0 [add other local routes here]”h]”hŒ}ifconfig arc0 MY.IP.ADD.RESS route add MY.IP.ADD.RESS arc0 route add -net SUB.NET.ADD.RESS arc0 [add other local routes here]”…”�”}”hj@sbah}”(h]”h ]”h"]”h$]”h&]”hÅhÆuh1j”h³hÇh´KÚhjubhþ)�”}”(hŒ=If you need arc0e (and only arc0e), it's a little different::”h]”hŒ>If you need arc0e (and only arc0e), it’s a little different:”…”�”}”(hjNh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Kßhjubj•)�”}”(hŒifconfig arc0 MY.IP.ADD.RESS ifconfig arc0e MY.IP.ADD.RESS route add MY.IP.ADD.RESS arc0e route add -net SUB.NET.ADD.RESS arc0e”h]”hŒifconfig arc0 MY.IP.ADD.RESS ifconfig arc0e MY.IP.ADD.RESS route add MY.IP.ADD.RESS arc0e route add -net SUB.NET.ADD.RESS arc0e”…”�”}”hj\sbah}”(h]”h ]”h"]”h$]”h&]”hÅhÆuh1j”h³hÇh´Káhjubhþ)�”}”(hŒ'arc0s works much the same way as arc0e.”h]”hŒ'arc0s works much the same way as arc0e.”…”�”}”(hjjh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Kæhjubeh}”(h]”h ]”h"]”h$]”h&]”uh1jhj h²hh³hÇh´Nubj)�”}”(hXÛMore than one protocol on the same wire. Now things start getting confusing. To even try it, you may need to be partly crazy. Here's what *I* did. :) Note that I don't include arc0s in my home network; I don't have any NetBSD or AmiTCP computers, so I only use arc0s during limited testing. I have three computers on my home network; two Linux boxes (which prefer RFC1201 protocol, for reasons listed above), and one XT that can't run Linux but runs the free Microsoft LANMAN Client instead. Worse, one of the Linux computers (freedom) also has a modem and acts as a router to my Internet provider. The other Linux box (insight) also has its own IP address and needs to use freedom as its default gateway. The XT (patience), however, does not have its own Internet IP address and so I assigned it one on a "private subnet" (as defined by RFC1597). To start with, take a simple network with just insight and freedom. Insight needs to: - talk to freedom via RFC1201 (arc0) protocol, because I like it more and it's faster. - use freedom as its Internet gateway. That's pretty easy to do. Set up insight like this:: ifconfig arc0 insight route add insight arc0 route add freedom arc0 /* I would use the subnet here (like I said to in "single protocol" above), but the rest of the subnet unfortunately lies across the PPP link on freedom, which confuses things. */ route add default gw freedom And freedom gets configured like so:: ifconfig arc0 freedom route add freedom arc0 route add insight arc0 /* and default gateway is configured by pppd */ Great, now insight talks to freedom directly on arc0, and sends packets to the Internet through freedom. If you didn't know how to do the above, you should probably stop reading this section now because it only gets worse. Now, how do I add patience into the network? It will be using LANMAN Client, which means I need the arc0e device. It needs to be able to talk to both insight and freedom, and also use freedom as a gateway to the Internet. (Recall that patience has a "private IP address" which won't work on the Internet; that's okay, I configured Linux IP masquerading on freedom for this subnet). So patience (necessarily; I don't have another IP number from my provider) has an IP address on a different subnet than freedom and insight, but needs to use freedom as an Internet gateway. Worse, most DOS networking programs, including LANMAN, have braindead networking schemes that rely completely on the netmask and a 'default gateway' to determine how to route packets. This means that to get to freedom or insight, patience WILL send through its default gateway, regardless of the fact that both freedom and insight (courtesy of the arc0e device) could understand a direct transmission. I compensate by giving freedom an extra IP address - aliased 'gatekeeper' - that is on my private subnet, the same subnet that patience is on. I then define gatekeeper to be the default gateway for patience. To configure freedom (in addition to the commands above):: ifconfig arc0e gatekeeper route add gatekeeper arc0e route add patience arc0e This way, freedom will send all packets for patience through arc0e, giving its IP address as gatekeeper (on the private subnet). When it talks to insight or the Internet, it will use its "freedom" Internet IP address. You will notice that we haven't configured the arc0e device on insight. This would work, but is not really necessary, and would require me to assign insight another special IP number from my private subnet. Since both insight and patience are using freedom as their default gateway, the two can already talk to each other. It's quite fortunate that I set things up like this the first time (cough cough) because it's really handy when I boot insight into DOS. There, it runs the Novell ODI protocol stack, which only works with RFC1201 ARCnet. In this mode it would be impossible for insight to communicate directly with patience, since the Novell stack is incompatible with Microsoft's Ethernet-Encap. Without changing any settings on freedom or patience, I simply set freedom as the default gateway for insight (now in DOS, remember) and all the forwarding happens "automagically" between the two hosts that would normally not be able to communicate at all. For those who like diagrams, I have created two "virtual subnets" on the same physical ARCnet wire. You can picture it like this:: [RFC1201 NETWORK] [ETHER-ENCAP NETWORK] (registered Internet subnet) (RFC1597 private subnet) (IP Masquerade) /---------------\ * /---------------\ | | * | | | +-Freedom-*-Gatekeeper-+ | | | | * | | \-------+-------/ | * \-------+-------/ | | | Insight | Patience (Internet) ”h]”(hþ)�”}”(hŒ(More than one protocol on the same wire.”h]”hŒ(More than one protocol on the same wire.”…”�”}”(hj‚h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Kéhj~ubhþ)�”}”(hŒûNow things start getting confusing. To even try it, you may need to be partly crazy. Here's what *I* did. :) Note that I don't include arc0s in my home network; I don't have any NetBSD or AmiTCP computers, so I only use arc0s during limited testing.”h]”(hŒeNow things start getting confusing. To even try it, you may need to be partly crazy. Here’s what ”…”�”}”(hj�h²hh³Nh´NubhŒemphasis”“”)�”}”(hŒ*I*”h]”hŒI”…”�”}”(hjšh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1j˜hj�ubhŒ™ did. :) Note that I don’t include arc0s in my home network; I don’t have any NetBSD or AmiTCP computers, so I only use arc0s during limited testing.”…”�”}”(hj�h²hh³Nh´Nubeh}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Këhj~ubhþ)�”}”(hŒÈI have three computers on my home network; two Linux boxes (which prefer RFC1201 protocol, for reasons listed above), and one XT that can't run Linux but runs the free Microsoft LANMAN Client instead.”h]”hŒÊI have three computers on my home network; two Linux boxes (which prefer RFC1201 protocol, for reasons listed above), and one XT that can’t run Linux but runs the free Microsoft LANMAN Client instead.”…”�”}”(hj²h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Kðhj~ubhþ)�”}”(hXeWorse, one of the Linux computers (freedom) also has a modem and acts as a router to my Internet provider. The other Linux box (insight) also has its own IP address and needs to use freedom as its default gateway. The XT (patience), however, does not have its own Internet IP address and so I assigned it one on a "private subnet" (as defined by RFC1597).”h]”hXiWorse, one of the Linux computers (freedom) also has a modem and acts as a router to my Internet provider. The other Linux box (insight) also has its own IP address and needs to use freedom as its default gateway. The XT (patience), however, does not have its own Internet IP address and so I assigned it one on a “private subnetâ€� (as defined by RFC1597).”…”�”}”(hjÀh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Kôhj~ubhþ)�”}”(hŒUTo start with, take a simple network with just insight and freedom. Insight needs to:”h]”hŒUTo start with, take a simple network with just insight and freedom. Insight needs to:”…”�”}”(hjÎh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Kúhj~ubj)�”}”(hŒ€- talk to freedom via RFC1201 (arc0) protocol, because I like it more and it's faster. - use freedom as its Internet gateway. ”h]”hŒ bullet_list”“”)�”}”(hhh]”(j)�”}”(hŒTtalk to freedom via RFC1201 (arc0) protocol, because I like it more and it's faster.”h]”hþ)�”}”(hŒTtalk to freedom via RFC1201 (arc0) protocol, because I like it more and it's faster.”h]”hŒVtalk to freedom via RFC1201 (arc0) protocol, because I like it more and it’s faster.”…”�”}”(hjéh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Kýhjåubah}”(h]”h ]”h"]”h$]”h&]”uh1jhjâubj)�”}”(hŒ%use freedom as its Internet gateway. ”h]”hþ)�”}”(hŒ$use freedom as its Internet gateway.”h]”hŒ$use freedom as its Internet gateway.”…”�”}”(hjh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Kÿhjýubah}”(h]”h ]”h"]”h$]”h&]”uh1jhjâubeh}”(h]”h ]”h"]”h$]”h&]”Œbullet”Œ-”uh1jàh³hÇh´KýhjÜubah}”(h]”h ]”h"]”h$]”h&]”uh1jh³hÇh´Kýhj~ubhþ)�”}”(hŒ5That's pretty easy to do. Set up insight like this::”h]”hŒ6That’s pretty easy to do. Set up insight like this:”…”�”}”(hj#h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Mhj~ubj•)�”}”(hXµifconfig arc0 insight route add insight arc0 route add freedom arc0 /* I would use the subnet here (like I said to in "single protocol" above), but the rest of the subnet unfortunately lies across the PPP link on freedom, which confuses things. */ route add default gw freedom”h]”hXµifconfig arc0 insight route add insight arc0 route add freedom arc0 /* I would use the subnet here (like I said to in "single protocol" above), but the rest of the subnet unfortunately lies across the PPP link on freedom, which confuses things. */ route add default gw freedom”…”�”}”hj1sbah}”(h]”h ]”h"]”h$]”h&]”hÅhÆuh1j”h³hÇh´Mhj~ubhþ)�”}”(hŒ%And freedom gets configured like so::”h]”hŒ$And freedom gets configured like so:”…”�”}”(hj?h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´M hj~ubj•)�”}”(hŒsifconfig arc0 freedom route add freedom arc0 route add insight arc0 /* and default gateway is configured by pppd */”h]”hŒsifconfig arc0 freedom route add freedom arc0 route add insight arc0 /* and default gateway is configured by pppd */”…”�”}”hjMsbah}”(h]”h ]”h"]”h$]”h&]”hÅhÆuh1j”h³hÇh´Mhj~ubhþ)�”}”(hŒßGreat, now insight talks to freedom directly on arc0, and sends packets to the Internet through freedom. If you didn't know how to do the above, you should probably stop reading this section now because it only gets worse.”h]”hŒáGreat, now insight talks to freedom directly on arc0, and sends packets to the Internet through freedom. If you didn’t know how to do the above, you should probably stop reading this section now because it only gets worse.”…”�”}”(hj[h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Mhj~ubhþ)�”}”(hX€Now, how do I add patience into the network? It will be using LANMAN Client, which means I need the arc0e device. It needs to be able to talk to both insight and freedom, and also use freedom as a gateway to the Internet. (Recall that patience has a "private IP address" which won't work on the Internet; that's okay, I configured Linux IP masquerading on freedom for this subnet).”h]”hXˆNow, how do I add patience into the network? It will be using LANMAN Client, which means I need the arc0e device. It needs to be able to talk to both insight and freedom, and also use freedom as a gateway to the Internet. (Recall that patience has a “private IP addressâ€� which won’t work on the Internet; that’s okay, I configured Linux IP masquerading on freedom for this subnet).”…”�”}”(hjih²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´Mhj~ubhþ)�”}”(hXQSo patience (necessarily; I don't have another IP number from my provider) has an IP address on a different subnet than freedom and insight, but needs to use freedom as an Internet gateway. Worse, most DOS networking programs, including LANMAN, have braindead networking schemes that rely completely on the netmask and a 'default gateway' to determine how to route packets. This means that to get to freedom or insight, patience WILL send through its default gateway, regardless of the fact that both freedom and insight (courtesy of the arc0e device) could understand a direct transmission.”h]”hXWSo patience (necessarily; I don’t have another IP number from my provider) has an IP address on a different subnet than freedom and insight, but needs to use freedom as an Internet gateway. Worse, most DOS networking programs, including LANMAN, have braindead networking schemes that rely completely on the netmask and a ‘default gateway’ to determine how to route packets. This means that to get to freedom or insight, patience WILL send through its default gateway, regardless of the fact that both freedom and insight (courtesy of the arc0e device) could understand a direct transmission.”…”�”}”(hjwh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´M hj~ubhþ)�”}”(hŒÐI compensate by giving freedom an extra IP address - aliased 'gatekeeper' - that is on my private subnet, the same subnet that patience is on. I then define gatekeeper to be the default gateway for patience.”h]”hŒÔI compensate by giving freedom an extra IP address - aliased ‘gatekeeper’ - that is on my private subnet, the same subnet that patience is on. I then define gatekeeper to be the default gateway for patience.”…”�”}”(hj…h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´M*hj~ubhþ)�”}”(hŒ:To configure freedom (in addition to the commands above)::”h]”hŒ9To configure freedom (in addition to the commands above):”…”�”}”(hj“h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´M.hj~ubj•)�”}”(hŒMifconfig arc0e gatekeeper route add gatekeeper arc0e route add patience arc0e”h]”hŒMifconfig arc0e gatekeeper route add gatekeeper arc0e route add patience arc0e”…”�”}”hj¡sbah}”(h]”h ]”h"]”h$]”h&]”hÅhÆuh1j”h³hÇh´M0hj~ubhþ)�”}”(hŒÚThis way, freedom will send all packets for patience through arc0e, giving its IP address as gatekeeper (on the private subnet). When it talks to insight or the Internet, it will use its "freedom" Internet IP address.”h]”hŒÞThis way, freedom will send all packets for patience through arc0e, giving its IP address as gatekeeper (on the private subnet). When it talks to insight or the Internet, it will use its “freedomâ€� Internet IP address.”…”�”}”(hj¯h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´M4hj~ubhþ)�”}”(hXCYou will notice that we haven't configured the arc0e device on insight. This would work, but is not really necessary, and would require me to assign insight another special IP number from my private subnet. Since both insight and patience are using freedom as their default gateway, the two can already talk to each other.”h]”hXEYou will notice that we haven’t configured the arc0e device on insight. This would work, but is not really necessary, and would require me to assign insight another special IP number from my private subnet. Since both insight and patience are using freedom as their default gateway, the two can already talk to each other.”…”�”}”(hj½h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´M9hj~ubhþ)�”}”(hX~It's quite fortunate that I set things up like this the first time (cough cough) because it's really handy when I boot insight into DOS. There, it runs the Novell ODI protocol stack, which only works with RFC1201 ARCnet. In this mode it would be impossible for insight to communicate directly with patience, since the Novell stack is incompatible with Microsoft's Ethernet-Encap. Without changing any settings on freedom or patience, I simply set freedom as the default gateway for insight (now in DOS, remember) and all the forwarding happens "automagically" between the two hosts that would normally not be able to communicate at all.”h]”hXˆIt’s quite fortunate that I set things up like this the first time (cough cough) because it’s really handy when I boot insight into DOS. There, it runs the Novell ODI protocol stack, which only works with RFC1201 ARCnet. In this mode it would be impossible for insight to communicate directly with patience, since the Novell stack is incompatible with Microsoft’s Ethernet-Encap. Without changing any settings on freedom or patience, I simply set freedom as the default gateway for insight (now in DOS, remember) and all the forwarding happens “automagicallyâ€� between the two hosts that would normally not be able to communicate at all.”…”�”}”(hjËh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´M?hj~ubhþ)�”}”(hŒƒFor those who like diagrams, I have created two "virtual subnets" on the same physical ARCnet wire. You can picture it like this::”h]”hŒ†For those who like diagrams, I have created two “virtual subnetsâ€� on the same physical ARCnet wire. You can picture it like this:”…”�”}”(hjÙh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´MIhj~ubj•)�”}”(hXd [RFC1201 NETWORK] [ETHER-ENCAP NETWORK] (registered Internet subnet) (RFC1597 private subnet) (IP Masquerade) /---------------\ * /---------------\ | | * | | | +-Freedom-*-Gatekeeper-+ | | | | * | | \-------+-------/ | * \-------+-------/ | | | Insight | Patience (Internet)”h]”hXd [RFC1201 NETWORK] [ETHER-ENCAP NETWORK] (registered Internet subnet) (RFC1597 private subnet) (IP Masquerade) /---------------\ * /---------------\ | | * | | | +-Freedom-*-Gatekeeper-+ | | | | * | | \-------+-------/ | * \-------+-------/ | | | Insight | Patience (Internet)”…”�”}”hjçsbah}”(h]”h ]”h"]”h$]”h&]”hÅhÆuh1j”h³hÇh´MMhj~ubeh}”(h]”h ]”h"]”h$]”h&]”uh1jhj h²hh³hÇh´Nubeh}”(h]”h ]”h"]”h$]”h&]”Œenumtype”Œarabic”Œprefix”hŒsuffix”Œ.”uh1j hj×h²hh³hÇh´KÑubeh}”(h]”Œusing-multiprotocol-arcnet”ah ]”h"]”Œusing multiprotocol arcnet”ah$]”h&]”uh1hÈhhÊh²hh³hÇh´K�ubhÉ)�”}”(hhh]”(hÎ)�”}”(hŒIt works: what now?”h]”hŒIt works: what now?”…”�”}”(hjh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hÍhjh²hh³hÇh´M]ubhþ)�”}”(hŒÖ:ref:`Send an email to netdev `. Describe your setup, preferably including driver version, kernel version, ARCnet card model, CPU type, number of systems on your network, and list of software in use.”h]”(h)�”}”(hŒ.:ref:`Send an email to netdev `”h]”hŒinline”“”)�”}”(hj%h]”hŒSend an email to netdev”…”�”}”(hj)h²hh³Nh´Nubah}”(h]”h ]”(Œxref”Œstd”Œstd-ref”eh"]”h$]”h&]”uh1j'hj#ubah}”(h]”h ]”h"]”h$]”h&]”Œrefdoc”Œnetworking/arcnet”Œ refdomain”j4Œreftype”Œref”Œ refexplicit”ˆŒrefwarn”ˆŒ reftarget”Œ arcnet-netdev”uh1hh³hÇh´M_hjubhŒ¨. Describe your setup, preferably including driver version, kernel version, ARCnet card model, CPU type, number of systems on your network, and list of software in use.”…”�”}”(hjh²hh³Nh´Nubeh}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´M_hjh²hubeh}”(h]”Œit-works-what-now”ah ]”h"]”Œit works: what now?”ah$]”h&]”uh1hÈhhÊh²hh³hÇh´M]ubhÉ)�”}”(hhh]”(hÎ)�”}”(hŒIt doesn't work: what now?”h]”hŒIt doesn’t work: what now?”…”�”}”(hj]h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hÍhjZh²hh³hÇh´Mdubhþ)�”}”(hŒÙDo the same as above, but also include the output of the ifconfig and route commands, as well as any pertinent log entries (ie. anything that starts with "arcnet:" and has shown up since the last reboot) in your mail.”h]”hŒÝDo the same as above, but also include the output of the ifconfig and route commands, as well as any pertinent log entries (ie. anything that starts with “arcnet:â€� and has shown up since the last reboot) in your mail.”…”�”}”(hjkh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´MfhjZh²hubhþ)�”}”(hXÚIf you want to try fixing it yourself (I strongly recommend that you mail me about the problem first, since it might already have been solved) you may want to try some of the debug levels available. For heavy testing on D_DURING or more, it would be a REALLY good idea to kill your klogd daemon first! D_DURING displays 4-5 lines for each packet sent or received. D_TX, D_RX, and D_SKB actually DISPLAY each packet as it is sent or received, which is obviously quite big.”h]”hXÚIf you want to try fixing it yourself (I strongly recommend that you mail me about the problem first, since it might already have been solved) you may want to try some of the debug levels available. For heavy testing on D_DURING or more, it would be a REALLY good idea to kill your klogd daemon first! D_DURING displays 4-5 lines for each packet sent or received. D_TX, D_RX, and D_SKB actually DISPLAY each packet as it is sent or received, which is obviously quite big.”…”�”}”(hjyh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´MjhjZh²hubhþ)�”}”(hX‚Once the driver is running, you can run the arcdump shell script (available from me or in the full ARCnet package, if you have it) as root to list the contents of the arcnet buffers at any time. To make any sense at all out of this, you should grab the pertinent RFCs. (some are listed near the top of arcnet.c). arcdump assumes your card is at 0xD0000. If it isn't, edit the script.”h]”hX„Once the driver is running, you can run the arcdump shell script (available from me or in the full ARCnet package, if you have it) as root to list the contents of the arcnet buffers at any time. To make any sense at all out of this, you should grab the pertinent RFCs. (some are listed near the top of arcnet.c). arcdump assumes your card is at 0xD0000. If it isn’t, edit the script.”…”�”}”(hj‡h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´MrhjZh²hubhþ)�”}”(hŒyBuffers 0 and 1 are used for receiving, and Buffers 2 and 3 are for sending. Ping-pong buffers are implemented both ways.”h]”hŒyBuffers 0 and 1 are used for receiving, and Buffers 2 and 3 are for sending. Ping-pong buffers are implemented both ways.”…”�”}”(hj•h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´MyhjZh²hubhþ)�”}”(hX¦If your debug level includes D_DURING and you did NOT define SLOW_XMIT_COPY, the buffers are cleared to a constant value of 0x42 every time the card is reset (which should only happen when you do an ifconfig up, or when Linux decides that the driver is broken). During a transmit, unused parts of the buffer will be cleared to 0x42 as well. This is to make it easier to figure out which bytes are being used by a packet.”h]”hX¦If your debug level includes D_DURING and you did NOT define SLOW_XMIT_COPY, the buffers are cleared to a constant value of 0x42 every time the card is reset (which should only happen when you do an ifconfig up, or when Linux decides that the driver is broken). During a transmit, unused parts of the buffer will be cleared to 0x42 as well. This is to make it easier to figure out which bytes are being used by a packet.”…”�”}”(hj£h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´M|hjZh²hubhþ)�”}”(hŒIYou can change the debug level without recompiling the kernel by typing::”h]”hŒHYou can change the debug level without recompiling the kernel by typing:”…”�”}”(hj±h²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´MƒhjZh²hubj•)�”}”(hŒ/ifconfig arc0 down metric 1xxx ifconfig arc0 up”h]”hŒ/ifconfig arc0 down metric 1xxx ifconfig arc0 up”…”�”}”hj¿sbah}”(h]”h ]”h"]”h$]”h&]”hÅhÆuh1j”h³hÇh´M…hjZh²hubhþ)�”}”(hŒŽwhere "xxx" is the debug level you want. For example, "metric 1015" would put you at debug level 15. Debug level 7 is currently the default.”h]”hŒ–where “xxxâ€� is the debug level you want. For example, “metric 1015â€� would put you at debug level 15. Debug level 7 is currently the default.”…”�”}”(hjÍh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´MˆhjZh²hubhþ)�”}”(hŒÒNote that the debug level is a binary combination of different debug flags; debug level 7 is really 1+2+4 or D_NORMAL+D_EXTRA+D_INIT. To include D_DURING, you would add 16 to this, resulting in debug level 23.”h]”hŒÒNote that the debug level is a binary combination of different debug flags; debug level 7 is really 1+2+4 or D_NORMAL+D_EXTRA+D_INIT. To include D_DURING, you would add 16 to this, resulting in debug level 23.”…”�”}”(hjÛh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´M‹hjZh²hubhþ)�”}”(hŒEIf you don't understand that, you probably don't want to know anyway.”h]”hŒIIf you don’t understand that, you probably don’t want to know anyway.”…”�”}”(hjéh²hh³Nh´Nubah}”(h]”h ]”h"]”h$]”h&]”uh1hýh³hÇh´M�hjZh²hubeh}”(h]”Œit-doesn-t-work-what-now”ah ]”h"]”Œit doesn't work: what now?”ah$]”h&]”uh1hÈhhÊh²hh³hÇh´Mdubeh}”(h]”Œarcnet”ah ]”h"]”Œarcnet”ah$]”h&]”uh1hÈhhh²hh³hÇh´Kubeh}”(h]”h ]”h"]”h$]”h&]”Œsource”hÇuh1hŒcurrent_source”NŒ current_line”NŒsettings”Œdocutils.frontend”ŒValues”“”)�”}”(hÍNŒ generator”NŒ datestamp”NŒ source_link”NŒ source_url”NŒ toc_backlinks”j$Œfootnote_backlinks”KŒ sectnum_xform”KŒstrip_comments”NŒstrip_elements_with_classes”NŒ strip_classes”NŒ report_level”KŒ halt_level”KŒexit_status_level”KŒdebug”NŒwarning_stream”NŒ traceback”ˆŒinput_encoding”Œ utf-8-sig”Œinput_encoding_error_handler”Œstrict”Œoutput_encoding”Œutf-8”Œoutput_encoding_error_handler”j) Œerror_encoding”Œutf-8”Œerror_encoding_error_handler”Œbackslashreplace”Œ language_code”Œen”Œrecord_dependencies”NŒconfig”NŒ id_prefix”hŒauto_id_prefix”Œid”Œ dump_settings”NŒdump_internals”NŒdump_transforms”NŒdump_pseudo_xml”NŒexpose_internals”NŒstrict_visitor”NŒ_disable_config”NŒ_source”hÇŒ _destination”NŒ _config_files”]”Œ7/var/lib/git/docbuild/linux/Documentation/docutils.conf”aŒfile_insertion_enabled”ˆŒ raw_enabled”KŒline_length_limit”M'Œpep_references”NŒ pep_base_url”Œhttps://peps.python.org/”Œpep_file_url_template”Œpep-%04d”Œrfc_references”NŒ rfc_base_url”Œ&https://datatracker.ietf.org/doc/html/”Œ tab_width”KŒtrim_footnote_reference_space”‰Œsyntax_highlight”Œlong”Œ smart_quotes”ˆŒsmartquotes_locales”]”Œcharacter_level_inline_markup”‰Œdoctitle_xform”‰Œ docinfo_xform”KŒsectsubtitle_xform”‰Œ image_loading”Œlink”Œembed_stylesheet”‰Œcloak_email_addresses”ˆŒsection_self_link”‰Œenv”NubŒreporter”NŒindirect_targets”]”Œsubstitution_defs”}”Œsubstitution_names”}”Œrefnames”}”Œrefids”}”j¦]”j›asŒnameids”}”(j j jàj¦jßjÜj/j,jdjajjjÔjÑj jjWjTjüjùuŒ nametypes”}”(j ‰jàˆj߉j/‰jd‰j‰jÔ‰j ‰jW‰jü‰uh}”(j hÊj¦j§jÜj§j,jçjaj2jjgjÑj jj×jTjjùjZuŒ footnote_refs”}”Œ citation_refs”}”Œ autofootnotes”]”Œautofootnote_refs”]”Œsymbol_footnotes”]”Œsymbol_footnote_refs”]”Œ footnotes”]”Œ citations”]”Œautofootnote_start”KŒsymbol_footnote_start”KŒ id_counter”Œ collections”ŒCounter”“”}”…”R”Œparse_messages”]”Œtransform_messages”]”hŒsystem_message”“”)�”}”(hhh]”hþ)�”}”(hhh]”hŒ3Hyperlink target "arcnet-netdev" is not referenced.”…”�”}”hj“ sbah}”(h]”h ]”h"]”h$]”h&]”uh1hýhj� ubah}”(h]”h ]”h"]”h$]”h&]”Œlevel”KŒtype”ŒINFO”Œsource”hÇŒline”K!uh1jŽ ubaŒ transformer”NŒ include_log”]”Œ decoration”Nh²hub.