summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Kleine-König <u.kleine-koenig@pengutronix.de>2011-06-24 20:32:43 +0200
committerUwe Kleine-König <u.kleine-koenig@pengutronix.de>2011-06-25 13:21:12 +0200
commit441103986b6f40d0304824dd5f4183b0af43cb6c (patch)
treecd46ebbb06dc40c734f6a0def49574ae8e1ed217
parente036ae96aca731e39f273adf4dfbe7a6f4fb3007 (diff)
downloadrt-tests-441103986b6f40d0304824dd5f4183b0af43cb6c.tar.gz
debian/rules: add build-{arch,indep} targets
Notice: this object is not reachable from any branch.
This fixes the following warnings from lintian: W: rt-tests source: debian-rules-missing-recommended-target build-arch W: rt-tests source: debian-rules-missing-recommended-target build-indep Debhelper 8.1.0 is the first version supporting the corresponding sequences, so bump Build-Depends. Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
Notice: this object is not reachable from any branch.
-rw-r--r--debian/changelog1
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules9
3 files changed, 8 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 6e1bea1..1a1e742 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ rt-tests (0.73-1) UNRELEASED; urgency=low
* new upstream release
* Fix dkms warning (Closes: LP: #681908). Patch by eraserix, thanks.
+ * add build-{arch,indep} targets to debian/rules
-- Uwe Kleine-König <u.kleine-koenig@pengutronix.de> Fri, 13 May 2011 12:22:25 +0200
diff --git a/debian/control b/debian/control
index db7e2b9..26b6227 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: misc
Priority: extra
Maintainer: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
Standards-Version: 3.9.1
-Build-Depends: debhelper (>= 7.4.15), libnuma-dev (>= 2.0.3) [amd64 i386 ia64 mips mipsel powerpc], dkms (>= 2.1.0.0)
+Build-Depends: debhelper (>= 8.1.0), libnuma-dev (>= 2.0.3) [amd64 i386 ia64 mips mipsel powerpc], dkms (>= 2.1.0.0)
Vcs-Browser: http://git.pengutronix.de/?p=ukl/rt-tests.git;
Vcs-Git: git://git.pengutronix.de/git/ukl/rt-tests.git
diff --git a/debian/rules b/debian/rules
index 5813fd3..dc19346 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,10 +8,13 @@ endif
DH = dh --with dkms
-build: build-stamp
+build-arch: build-arch-stamp
+build-indep:
+build: build-arch build-indep
+
install: build install-stamp
-build-stamp install-stamp:
+build-arch-stamp install-stamp:
$(DH) ${@:-stamp=}
touch $@
@@ -23,4 +26,4 @@ binary: binary-arch binary-indep
clean:
$(DH) $@
-.PHONY: build clean install binary-indep binary-arch binary
+.PHONY: build-arch build-indep build clean install binary-indep binary-arch binary